MongoDB Extension for Yii 2

Posted by Steven on 2016-11-03

Installation

This extension requires MongoDB PHP Extension version 1.0.0 or higher.

This extension requires MongoDB server version 3.0 or higher.

The preferred way to install this extension is through composer.

Either run

1
php composer.phar require --prefer-dist yiisoft/yii2-mongodb

or add

1
"yiisoft/yii2-mongodb": "~2.1.0"

to the require section of your composer.json.

Configuration

To use this extension, simply add the following code in your application configuration:

1
2
3
4
5
6
7
8
9
10
11
12
13
return [
//....
'components' => [
'mongodb' => [
'class' => '\yii\mongodb\Connection',
'dsn' => 'mongodb://localhost:27017/mydatabase',
'options' => [
"username" => "Username",
"password" => "Password"
]
],
],
];

推荐文章